Mac Ports

Mac ports で PHP 5.4 と PHP 5.5 を開発ターゲットにあわせて切り替える

  • Posted on: 8 October 2014
  • By: miyabe

うちのようなソフトウェアの受託開発に携わる事業者であれば、お客さんの要望によって PHP のバージョンが変わるのに柔軟に対応しなければならない。

例えば、現在開発中のシステムが PHP 5.5 で開発している途中だとする。
そこに、別のお客さんから、保守契約中のシステムのバグ報告があったとする。
そんなときには、一時的に PHP 5.4 に変更し、すぐにバグの原因を調べなければならない。

そのための仕組みが Mac Ports には存在している。以下のコマンドで、PHP 5.4 から PHP 5.5 への変更や、PHP 5.5 から PHP 5.4 への変更が簡単におこなえる。